CVE-2025-11266
CVE-2025-11266 · Grassroots DICOM (GDCM) Out-of-bounds Write
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An out-of-bounds write vulnerability exists in the Grassroots DICOM library (GDCM). The issue is triggered during parsing of a malformed DICOM file containing encapsulated PixelData fragments (compressed image data stored as multiple fragments). This vulnerability leads to a segmentation fault caused by an out-of-bounds memory access due to unsigned integer underflow in buffer indexing. It is exploitable via file input, simply opening a crafted malicious DICOM file is sufficient to trigger the crash, resulting in a denial-of-service condition.
CVSS 6.8 · Medium · EPSS 0.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
dicom (gdcm)
- Versions
- ≥ 0, ≤ 3.0.24: Affected (custom)
No fix published
simpleitk
- Versions
- ≥ 0, ≤ 2.5.2: Affected (custom)
No fix published
medinria
- Versions
- ≥ 0, ≤ 4.0: Affected (custom)
No fix published
gdcm Debian:12
- Versions
- 3.0.21-1
- 3.0.21-2
- 3.0.22-1
- 3.0.22-2
- 3.0.22-2.1
- 3.0.22-2.1~exp1
- 3.0.22-3
- 3.0.24-1
- 3.0.24-1+hurd.1
- 3.0.24-10
- 3.0.24-11
- 3.0.24-12
- 3.0.24-13
- 3.0.24-14
- 3.0.24-2
- 3.0.24-3
- 3.0.24-3+hurd.1
- 3.0.24-4
- 3.0.24-5
- 3.0.24-5+hurd.1
- 3.0.24-5+hurd.2
- 3.0.24-6
- 3.0.24-7
- 3.0.24-8
- 3.0.24-9
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gdcm Debian:13
- Versions
- 3.0.24-10
- 3.0.24-11
- 3.0.24-12
- 3.0.24-13
- 3.0.24-14
- 3.0.24-5
- 3.0.24-5+hurd.1
- 3.0.24-5+hurd.2
- 3.0.24-6
- 3.0.24-7
- 3.0.24-8
- 3.0.24-9
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gdcm Debian:14
- Versions
- 3.0.24-10
- 3.0.24-5
- 3.0.24-5+hurd.1
- 3.0.24-5+hurd.2
- 3.0.24-6
- 3.0.24-7
- 3.0.24-8
- 3.0.24-9
- Affected ranges
- ECOSYSTEM: < 3.0.24-11
Update to 3.0.24-11
gdcm Ubuntu:Pro:14.04:LTS
- Versions
- 2.2.3-2ubuntu3
- 2.2.3-2ubuntu4
- 2.2.4-1.1ubuntu1
- 2.2.4-1.1ubuntu2
- 2.2.4-1.1ubuntu3
- 2.2.4-1.1ubuntu4
- 2.2.4-1.1ubuntu4+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gdcm Ubuntu:16.04:LTS
- Versions
- 2.4.4-4
- 2.4.4-4build1
- 2.4.4-4ubuntu1
- 2.6.1-3
- 2.6.2-1
- 2.6.2-2
- 2.6.2-3
- 2.6.3-1
- 2.6.3-1ubuntu1
- 2.6.3-2ubuntu1
- 2.6.3-3ubuntu1
- 2.6.3-3ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gdcm Ubuntu:18.04:LTS
- Versions
- 2.8.2-3build1
- 2.8.3-1
- 2.8.4-1
- 2.8.4-1build2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gdcm Ubuntu:20.04:LTS
- Versions
- 2.8.8-9ubuntu4
- 2.8.8-9ubuntu5
- 3.0.4-2
- 3.0.4-2build1
- 3.0.4-2ubuntu1
- 3.0.5-1ubuntu1
- 3.0.5-1.1ubuntu1
- 3.0.5-1.1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gdcm Ubuntu:22.04:LTS
- Versions
- 3.0.8-2
- 3.0.10-1
- 3.0.10-1build2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gdcm Ubuntu:24.04:LTS
- Versions
- 3.0.21-2
- 3.0.22-1
- 3.0.22-2build1
- 3.0.22-2build2
- 3.0.22-2.1build1
- 3.0.22-2.1build2
- 3.0.22-2.1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gdcm Ubuntu:25.10
- Versions
- 3.0.24-5ubuntu2
- 3.0.24-5ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/malaterre/GDCM/releases/tag/v3.2.2
- https://www.cisa.gov/news-events/ics-medical-advisories/icsma-25-345-01
- https://github.com/cisagov/CSAF/blob/develop/csaf_files/OT/white/2025/icsma-25-345-01.json
- https://github.com/malaterre/GDCM/commit/5829c95c8ac3afa9a3a3413675e948959c28a789
- https://nvd.nist.gov/vuln/detail/CVE-2025-11266