p PatchFirst

PatchFirst · Latest vulnerabilities

gdcm vulnerabilities

Vulnerabilities published for gdcm in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 13

  1. CVE-2026-3650

    High · CVSS 8.7EPSS 0.36%No fix published

    Grassroots DICOM Missing release of memory after effective lifetime

    A memory leak exists in the Grassroots DICOM library (GDCM). The bug occurs when parsing malformed DICOM files with non-standard VR types in file meta information. The vulnerability leads to vast memory allocations and resource depletion, triggering a denial-of-service condition. A maliciously crafted file can fill the heap in a single read operation without properly releasing it.

    Published Updated
  2. CVE-2025-53619

    High · CVSS 7.4EPSS 0.34%No fix published

    CVE-2025-53619

    An out-of-bounds read vulnerability exists in the JPEGBITSCodec::InternalCode functionality of Grassroot DICOM 3.024. A specially crafted DICOM file can lead to an information leak. An attacker can provide a malicious file to trigger this vulnerability.The function `null_convert` is called based of the value of the malicious DICOM file specifying the intended interpretation of the image pixel data

    Published Updated
  3. CVE-2025-53618

    High · CVSS 7.4EPSS 0.32%No fix published

    CVE-2025-53618

    An out-of-bounds read vulnerability exists in the JPEGBITSCodec::InternalCode functionality of Grassroot DICOM 3.024. A specially crafted DICOM file can lead to an information leak. An attacker can provide a malicious file to trigger this vulnerability.The function `grayscale_convert` is called based of the value of the malicious DICOM file specifying the intended interpretation of the image pixel data

    Published Updated
  4. CVE-2025-11266

    Medium · CVSS 6.8EPSS 0.15%No fix published

    Grassroots DICOM (GDCM) Out-of-bounds Write

    An out-of-bounds write vulnerability exists in the Grassroots DICOM library (GDCM). The issue is triggered during parsing of a malformed DICOM file containing encapsulated PixelData fragments (compressed image data stored as multiple fragments). This vulnerability leads to a segmentation fault caused by an out-of-bounds memory access due to unsigned integer underflow in buffer indexing. It is exploitable via file input, simply opening a crafted malicious DICOM file is sufficient to trigger the crash, resulting in a denial-of-service condition.

    Published Updated
  5. CVE-2015-8397

    High · CVSS 8.2EPSS 3.61%Fix available

    CVE-2015-8397

    The JPEGLSCodec::DecodeExtent function in MediaStorageAndFileFormat/gdcmJPEGLSCodec.cxx in Grassroots DICOM (aka GDCM) before 2.6.2 allows remote attackers to obtain sensitive information from process memory or cause a denial of service (application crash) via an embedded JPEG-LS image with dimensions larger than the selected region in a (1) two-dimensional or (2) three-dimensional DICOM image file, which triggers an out-of-bounds read.

    • Update to 2.6.2-1
    Published Updated
  6. CVE-2015-8396

    Critical · CVSS 10EPSS 16.03%Public exploitFix available

    CVE-2015-8396

    Integer overflow in the ImageRegionReader::ReadIntoBuffer function in MediaStorageAndFileFormat/gdcmImageRegionReader.cxx in Grassroots DICOM (aka GDCM) before 2.6.2 allows attackers to execute arbitrary code via crafted header dimensions in a DICOM image file, which triggers a buffer overflow.

    • Update to 2.6.2-1
    Published Updated
  7. CVE-2009-3560

    Not ratedEPSS 24.31%Fix available

    CVE-2009-3560

    The big2_toUtf8 function in lib/xmltok.c in libexpat in Expat 2.0.1, as used in the XML-Twig module for Perl, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with malformed UTF-8 sequences that trigger a buffer over-read, related to the doProlog function in lib/xmlparse.c, a different vulnerability than CVE-2009-2625 and CVE-2009-3720.

    • Update to 2.0.14-2
    Published Updated
  8. CVE-2009-3720

    Not ratedEPSS 27.92%Fix available

    CVE-2009-3720

    The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.

    • Update to 2.0.14-2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →