p PatchFirst

CVE-2025-12613

CVE-2025-12613

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions of the package cloudinary before 2.7.0 are vulnerable to Arbitrary Argument Injection due to improper parsing of parameter values containing an ampersand. An attacker can inject additional, unintended parameters. This could lead to a variety of malicious outcomes, such as bypassing security checks, altering data, or manipulating the application's behavior. **Note:** Following our established security policy, we attempted to contact the maintainer regarding this vulnerability, but haven't received a response.

CVSS 8.8 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • cloudinary

    Versions
    • ≥ 0, < 2.7.0: Affected (semver)

    Update to 2.7.0

  • cloudinary npm

    Affected ranges
    • SEMVER: < 2.7.0

    Update to 2.7.0

Original sources

Check your server →