CVE-2025-14675
CVE-2025-14675 · Meta Box <= 5.11.1 - Authenticated (Contributor+) Arbitrary File Deletion
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The Meta Box plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the 'ajax_delete_file' function in all versions up to, and including, 5.11.1. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).
CVSS 7.2 · High · EPSS 2.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
meta box
- Versions
- ≥ 0, ≤ 5.11.1: Affected (semver)
No fix published
wpmetabox/meta-box Packagist
- Versions
- 4.10
- 4.10.1
- 4.10.2
- 4.10.3
- 4.10.4
- 4.11
- 4.11.1
- 4.11.2
- 4.11.3
- 4.12
- 4.12.1
- 4.12.2
- 4.12.3
- 4.12.4
- 4.12.5
- 4.12.6
- 4.13.0
- 4.13.1
- 4.13.2
- 4.13.3
- 4.13.4
- 4.14.0
- 4.14.1
- 4.14.10
- 4.14.11
- 4.14.2
- 4.14.3
- 4.14.4
- 4.14.5
- 4.14.6
- 4.14.7
- 4.14.8
- 4.14.9
- 4.15.0
- 4.15.1
- 4.15.2
- 4.15.3
- 4.15.4
- 4.15.5
- 4.15.6
- 4.15.7
- 4.15.8
- 4.15.9
- 4.16.0
- 4.16.1
- 4.16.2
- 4.16.3
- 4.17.0
- 4.17.1
- 4.17.2
- 4.17.3
- 4.18.0
- 4.18.1
- 4.18.2
- 4.18.3
- 4.18.4
- 4.4.0
- 4.4.1
- 4.5.1
- 4.5.2
- 4.5.3
- 4.5.4
- 4.5.5
- 4.5.6
- 4.5.7
- 4.6
- 4.7
- 4.7.1
- 4.7.2
- 4.7.3
- 4.8.0
- 4.8.1
- 4.8.3
- 4.8.4
- 4.8.5
- 4.8.6
- 4.8.7
- 4.9
- 4.9.1
- 4.9.2
- 4.9.3
- 4.9.4
- 4.9.5
- 4.9.6
- 5.0.0
- 5.0.1
- 5.1.0
- 5.1.1
- 5.1.2
- 5.10.0
- 5.10.1
- 5.10.10
- 5.10.11
- 5.10.12
- 5.10.13
- 5.10.14
- 5.10.15
- 5.10.16
- 5.10.17
- 5.10.18
- 5.10.19
- 5.10.2
- 5.10.3
- 5.10.4
- 5.10.5
- 5.10.6
- 5.10.7
- 5.10.8
- 5.10.9
- 5.11.0
- 5.11.1
- 5.2.0
- 5.2.1
- 5.2.10
- 5.2.2
- 5.2.3
- 5.2.4
- 5.2.5
- 5.2.6
- 5.2.7
- 5.2.8
- 5.2.9
- 5.3.0
- 5.3.1
- 5.3.10
- 5.3.2
- 5.3.3
- 5.3.4
- 5.3.5
- 5.3.6
- 5.3.7
- 5.3.8
- 5.3.9
- 5.4.0
- 5.4.1
- 5.4.2
- 5.4.3
- 5.4.4
- 5.4.5
- 5.4.6
- 5.4.7
- 5.4.8
- 5.5.0
- 5.5.1
- 5.6.0
- 5.6.1
- 5.6.10
- 5.6.11
- 5.6.12
- 5.6.13
- 5.6.14
- 5.6.15
- 5.6.16
- 5.6.17
- 5.6.18
- 5.6.2
- 5.6.3
- 5.6.4
- 5.6.5
- 5.6.6
- 5.6.7
- 5.6.8
- 5.6.9
- 5.7.0
- 5.7.1
- 5.7.2
- 5.7.3
- 5.7.4
- 5.7.5
- 5.8.0
- 5.8.1
- 5.8.2
- 5.9.0
- 5.9.1
- 5.9.10
- 5.9.11
- 5.9.2
- 5.9.3
- 5.9.4
- 5.9.5
- 5.9.6
- 5.9.7
- 5.9.8
- 5.9.9
- Affected ranges
- ECOSYSTEM: < 5.11.2
Update to 5.11.2
Original sources
- https://www.wordfence.com/threat-intel/vulnerabilities/id/036467de-95bb-4bfd-9522-df8dc17f3102?source=cve
- https://plugins.trac.wordpress.org/changeset/3475210/meta-box#file3
- https://plugins.trac.wordpress.org/browser/meta-box/tags/5.11.0/inc/fields/file.php#L30
- https://plugins.trac.wordpress.org/browser/meta-box/tags/5.11.0/inc/fields/file.php#L54
- https://github.com/wpmetabox/meta-box/pull/1654
- https://nvd.nist.gov/vuln/detail/CVE-2025-14675