CVE-2025-15346
CVE-2025-15346 · wolfSSL Python library `CERT_REQUIRED` mode fails to enforce client certificate requirement
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability in the handling of verify_mode = CERT_REQUIRED in the wolfssl Python package (wolfssl-py) causes client certificate requirements to not be fully enforced. Because the WOLFSSL_VERIFY_FAIL_IF_NO_PEER_CERT flag was not included, the behavior effectively matched CERT_OPTIONAL: a peer certificate was verified if presented, but connections were incorrectly authenticated when no client certificate was provided. This results in improper authentication, allowing attackers to bypass mutual TLS (mTLS) client authentication by omitting a client certificate during the TLS handshake. The issue affects versions up to and including 5.8.2.
CVSS 9.3 · Critical · EPSS 0.3% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
wolfssl-py
- Versions
- ≥ 5.3.0, ≤ 5.8.2: Affected (python)
No fix published
wolfssl PyPI
- Versions
- 0.1.0
- 0.1.1
- 0.1.2
- 3.12.2.post0
- 3.13.0.post0
- 3.13.0.post1
- 3.14.0.post1
- 4.1.0.post0
- 5.3.0.post0
- 5.4.0.post0
- 5.5.3.post0
- 5.5.4.post0
- 5.6.0.post0
- 5.6.6.post0
- 5.7.2.post0
- 5.7.4.post0
- 5.8.2.post0
- Affected ranges
- ECOSYSTEM: < 5.8.4.post0
Update to 5.8.4.post0