p PatchFirst

PatchFirst · Latest vulnerabilities

wolfssl vulnerabilities

Vulnerabilities published for wolfssl in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2025-15346

    Critical · CVSS 9.3EPSS 0.33%Fix available

    wolfSSL Python library `CERT_REQUIRED` mode fails to enforce client certificate requirement

    A vulnerability in the handling of verify_mode = CERT_REQUIRED in the wolfssl Python package (wolfssl-py) causes client certificate requirements to not be fully enforced.  Because the WOLFSSL_VERIFY_FAIL_IF_NO_PEER_CERT flag was not included, the behavior effectively matched CERT_OPTIONAL: a peer certificate was verified if presented, but connections were incorrectly authenticated when no client certificate was provided.  This results in improper authentication, allowing attackers to bypass mutual TLS (mTLS) client authentication by omitting a client certificate during the TLS handshake.  The issue affects versions up to and including 5.8.

    • Update to 5.8.4.post0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →