CVE-2025-2123
CVE-2025-2123 · GeSHi CSS cssgen.php get_var cross site scripting
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability, which was classified as problematic, has been found in GeSHi up to 1.0.9.1. Affected by this issue is the function get_var of the file /contrib/cssgen.php of the component CSS Handler. The manipulation of the argument default-styles/keywords-1/keywords-2/keywords-3/keywords-4/comments leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used.
CVSS 5.1 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Affected products and versions
geshi
- Versions
- 1.0.9.0: Affected
- 1.0.9.1: Affected
No fix published
geshi Debian:12
- Affected ranges
- ECOSYSTEM: < 1.0.8.4-2
Update to 1.0.8.4-2
geshi Debian:13
- Affected ranges
- ECOSYSTEM: < 1.0.8.4-2
Update to 1.0.8.4-2
geshi Debian:14
- Affected ranges
- ECOSYSTEM: < 1.0.8.4-2
Update to 1.0.8.4-2
geshi/geshi Packagist
- Versions
- v1.0.8.12
- v1.0.8.13
- v1.0.9.0
- v1.0.9.1
- Affected ranges
- ECOSYSTEM: ≤ 1.0.9.1
No fix published
geshi Ubuntu:16.04:LTS
- Versions
- 1.0.8.11-2
- 1.0.8.11-2ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geshi Ubuntu:18.04:LTS
- Versions
- 1.0.8.11-2.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geshi Ubuntu:20.04:LTS
- Versions
- 1.0.8.11-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geshi Ubuntu:22.04:LTS
- Versions
- 1.0.9.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geshi Ubuntu:24.04:LTS
- Versions
- 1.0.9.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geshi Ubuntu:25.10
- Versions
- 1.0.9.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geshi Ubuntu:26.10
- Versions
- 1.0.9.1-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
geshi Ubuntu:26.04:LTS
- Versions
- 1.0.9.1-1
- 1.0.9.1-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published