p PatchFirst

PatchFirst · Latest vulnerabilities

geshi vulnerabilities

Vulnerabilities published for geshi in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2025-2123

    Medium · CVSS 5.1EPSS 0.47%Fix available

    GeSHi CSS cssgen.php get_var cross site scripting

    A vulnerability, which was classified as problematic, has been found in GeSHi up to 1.0.9.1. Affected by this issue is the function get_var of the file /contrib/cssgen.php of the component CSS Handler. The manipulation of the argument default-styles/keywords-1/keywords-2/keywords-3/keywords-4/comments leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used.

    • Update to 1.0.8.4-2
    Published Updated
  2. CVE-2008-5186

    Not ratedEPSS 1.97%Fix available

    CVE-2008-5186

    The set_language_path function in geshi.php in Generic Syntax Highlighter (GeSHi) before 1.0.8.1 might allow remote attackers to conduct file inclusion attacks via crafted inputs that influence the default language path ($path variable). NOTE: this issue has been disputed by a vendor, stating that only a static value is used, so this is not a vulnerability in GeSHi. Separate CVE identifiers would be created for web applications that integrate GeSHi in a way that allows control of the default language path

    • Update to 1.0.8.1-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →