p PatchFirst

CVE-2025-2691

CVE-2025-2691

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions of the package nossrf before 1.0.4 are vulnerable to Server-Side Request Forgery (SSRF) where an attacker can provide a hostname that resolves to a local or reserved IP address space and bypass the SSRF protection mechanism.

CVSS 8.8 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • nossrf

    Versions
    • ≥ 0, < 1.0.4: Affected (semver)

    Update to 1.0.4

  • nossrf npm

    Affected ranges
    • SEMVER: < 1.0.4

    Update to 1.0.4

Original sources

Check your server →