CVE-2025-30212
CVE-2025-30212 · Frappe has possibility of SQL injection due to improper validations
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Frappe is a full-stack web application framework. An SQL Injection vulnerability has been identified in Frappe Framework prior to versions 14.89.0 and 15.51.0 which could allow a malicious actor to access sensitive information. Versions 14.89.0 and 15.51.0 fix the issue. Upgrading is required; no other workaround is present.
CVSS 6.6 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
frappe
- Versions
- < 14.89.0: Affected
- >= 15.0.0, < 15.51.0: Affected
No fix published
frappe PyPI
- Versions
- 0.0.1
- Affected ranges
- ECOSYSTEM: < 14.89.0
Update to 14.89.0
frappe PyPI
- Affected ranges
- ECOSYSTEM: ≥ 15.0.0, < 15.51.0
Update to 15.51.0
frappe PyPI
- Versions
- 0.0.1
- Affected ranges
- ECOSYSTEM: < 14.89.0 ∪ ≥ 15.0.0, < 15.51.0
Update to 14.89.0; Update to 15.51.0