p PatchFirst

PatchFirst · Latest vulnerabilities

frappe vulnerabilities

Vulnerabilities published for frappe in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2025-30217

    Medium · CVSS 6.6EPSS 0.37%Fix available

    Frappe has possibility of SQL injection due to improper validations

    Frappe is a full-stack web application framework. Prior to versions 14.93.2 and 15.55.0, a SQL Injection vulnerability has been identified in Frappe Framework which could allow a malicious actor to access sensitive information. Versions 14.93.2 and 15.55.0 contain a patch for the issue. No known workarounds are available.

    • Update to 14.93.2
    • Update to 15.55.0
    Published Updated
  2. CVE-2025-30214

    High · CVSS 8EPSS 0.41%Fix available

    Frappe vulnerable to information disclosure leading to account takeover

    Frappe is a full-stack web application framework. Prior to versions 14.89.0 and 15.51.0, making crafted requests could lead to information disclosure that could further lead to account takeover. Versions 14.89.0 and 15.51.0 fix the issue. There's no workaround to fix this without upgrading.

    • Update to 14.89.0
    • Update to 15.51.0
    Published Updated
  3. CVE-2025-30213

    Medium · CVSS 6.3EPSS 0.72%Fix available

    Frappe has Possibility of Remote Code Execution due to improper validation

    Frappe is a full-stack web application framework. Prior to versions 14.91.0 and 15.52.0, a system user was able to create certain documents in a specific way that could lead to remote code execution. Versions 14.9.1 and 15.52.0 contain a patch for the vulnerability. There's no workaround; an upgrade is required.

    • Update to 14.91.0
    • Update to 15.52.0
    Published Updated
  4. CVE-2025-30212

    Medium · CVSS 6.6EPSS 0.44%Fix available

    Frappe has possibility of SQL injection due to improper validations

    Frappe is a full-stack web application framework. An SQL Injection vulnerability has been identified in Frappe Framework prior to versions 14.89.0 and 15.51.0 which could allow a malicious actor to access sensitive information. Versions 14.89.0 and 15.51.0 fix the issue. Upgrading is required; no other workaround is present.

    • Update to 14.89.0
    • Update to 15.51.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →