CVE-2025-30213
CVE-2025-30213 · Frappe has Possibility of Remote Code Execution due to improper validation
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Frappe is a full-stack web application framework. Prior to versions 14.91.0 and 15.52.0, a system user was able to create certain documents in a specific way that could lead to remote code execution. Versions 14.9.1 and 15.52.0 contain a patch for the vulnerability. There's no workaround; an upgrade is required.
CVSS 6.3 · Medium · EPSS 0.7% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
frappe
- Versions
- < 14.91.0: Affected
- >= 15.0.0, < 15.52.0: Affected
No fix published
frappe PyPI
- Versions
- 0.0.1
- Affected ranges
- ECOSYSTEM: < 14.91.0
Update to 14.91.0
frappe PyPI
- Affected ranges
- ECOSYSTEM: ≥ 15.0.0, < 15.52.0
Update to 15.52.0
frappe PyPI
- Versions
- 0.0.1
- Affected ranges
- ECOSYSTEM: < 14.91.0 ∪ ≥ 15.0.0, < 15.52.0
Update to 14.91.0; Update to 15.52.0