CVE-2025-30217
CVE-2025-30217 · Frappe has possibility of SQL injection due to improper validations
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Frappe is a full-stack web application framework. Prior to versions 14.93.2 and 15.55.0, a SQL Injection vulnerability has been identified in Frappe Framework which could allow a malicious actor to access sensitive information. Versions 14.93.2 and 15.55.0 contain a patch for the issue. No known workarounds are available.
CVSS 6.6 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
frappe
- Versions
- < 14.93.2: Affected
- >= 15.0.0, < 15.55.0: Affected
No fix published
frappe PyPI
- Versions
- 0.0.1
- Affected ranges
- ECOSYSTEM: < 14.93.2
Update to 14.93.2
frappe PyPI
- Affected ranges
- ECOSYSTEM: ≥ 15.0.0, < 15.55.0
Update to 15.55.0
frappe PyPI
- Versions
- 0.0.1
- Affected ranges
- ECOSYSTEM: < 14.93.2 ∪ ≥ 15.0.0, < 15.55.0
Update to 14.93.2; Update to 15.55.0