CVE-2025-30473
CVE-2025-30473 · Apache Airflow Common SQL Provider: Remote Code Execution via Sql Injection
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow Common SQL Provider. When using the partition clause in SQLTableCheckOperator as parameter (which was a recommended pattern), Authenticated UI User could inject arbitrary SQL command when triggering DAG exposing partition_clause to the user. This allowed the DAG Triggering user to escalate privileges to execute those arbitrary commands which they normally would not have. This issue affects Apache Airflow Common SQL Provider: before 1.24.1. Users are recommended to upgrade to version 1.24.1, which fixes the issue.
CVSS 8.8 · High · EPSS 1.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow common sql provider
- Versions
- ≥ 0, < 1.24.1: Affected (semver)
Update to 1.24.1
apache-airflow-providers-common-sql PyPI
- Versions
- 1.0.0
- 1.0.0a1
- 1.0.0rc1
- 1.1.0
- 1.1.0rc1
- 1.1.0rc2
- 1.1.0rc3
- 1.1.0rc4
- 1.10.0
- 1.10.0rc1
- 1.10.1
- 1.10.1rc1
- 1.11.0
- 1.11.0rc1
- 1.11.0rc2
- 1.11.0rc3
- 1.11.1
- 1.11.1rc1
- 1.12.0
- 1.12.0rc1
- 1.13.0
- 1.13.0rc1
- 1.14.0
- 1.14.0rc1
- 1.14.1
- 1.14.1rc1
- 1.14.2
- 1.14.2rc1
- 1.15.0
- 1.15.0rc1
- 1.16.0
- 1.16.0rc1
- 1.17.0
- 1.17.0rc1
- 1.17.1
- 1.17.1rc1
- 1.18.0
- 1.18.0rc1
- 1.19.0
- 1.19.0rc1
- 1.2.0
- 1.2.0rc1
- 1.20.0
- 1.20.0rc1
- 1.21.0
- 1.21.0rc1
- 1.21.0rc2
- 1.22.0
- 1.23.0
- 1.23.0rc1
- 1.24.0
- 1.24.0rc1
- 1.24.1b1
- 1.24.1rc1
- 1.3.0
- 1.3.0rc1
- 1.3.1
- 1.3.1rc2
- 1.3.1rc3
- 1.3.2
- 1.3.2rc1
- 1.3.2rc2
- 1.3.3
- 1.3.3rc1
- 1.3.4
- 1.3.4rc1
- 1.4.0
- 1.4.0rc1
- 1.5.0
- 1.5.0rc1
- 1.5.0rc2
- 1.5.1
- 1.5.1rc1
- 1.5.2
- 1.5.2rc1
- 1.6.0
- 1.6.0rc1
- 1.6.0rc2
- 1.6.1
- 1.6.1rc1
- 1.6.2
- 1.6.2rc1
- 1.7.0
- 1.7.0rc1
- 1.7.1
- 1.7.1rc1
- 1.7.2
- 1.7.2rc1
- 1.8.0
- 1.8.0rc1
- 1.8.1
- 1.8.1rc1
- 1.9.0
- 1.9.0rc1
- Affected ranges
- ECOSYSTEM: < 1.24.1
Update to 1.24.1
Original sources
- https://github.com/apache/airflow/pull/48098
- https://lists.apache.org/thread/53klkv790cylqcop0350w7nfq1y6h0t2
- http://www.openwall.com/lists/oss-security/2025/04/04/2
- http://www.openwall.com/lists/oss-security/2025/04/06/1
- http://www.openwall.com/lists/oss-security/2025/04/06/2
- http://www.openwall.com/lists/oss-security/2025/04/06/3
- https://nvd.nist.gov/vuln/detail/CVE-2025-30473