p PatchFirst

PatchFirst · Latest vulnerabilities

apache-airflow-providers-common-sql vulnerabilities

Vulnerabilities published for apache-airflow-providers-common-sql in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2025-30473

    High · CVSS 8.8EPSS 0.95%Fix available

    Apache Airflow Common SQL Provider: Remote Code Execution via Sql Injection

    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow Common SQL Provider. When using the partition clause in SQLTableCheckOperator as parameter (which was a recommended pattern), Authenticated UI User could inject arbitrary SQL command when triggering DAG exposing partition_clause to the user. This allowed the DAG Triggering user to escalate privileges to execute those arbitrary commands which they normally would not have. This issue affects Apache Airflow Common SQL Provider: before 1.24.1. Users are recommended to upgrade to version 1.24.1, which fixes the issue.

    • Update to 1.24.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →