p PatchFirst

CVE-2025-3130

CVE-2025-3130 · Obfuscate - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-029

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Obfuscate allows Stored XSS.This issue affects Obfuscate: from 0.0.0 before 2.0.1.

CVSS 5.4 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • obfuscate

    Versions
    • ≥ 0.0.0, < 2.0.1: Affected (semver)

    Update to 2.0.1

  • drupal/obfuscate Packagist:https://packages.drupal.org/8

    Affected ranges
    • ECOSYSTEM: < 2.0.1

    Update to 2.0.1

  • drupal/obfuscate Packagist

    Affected ranges
    • ECOSYSTEM: < 2.0.1

    Update to 2.0.1

Original sources

Check your server →