CVE-2025-31684
CVE-2025-31684 · OAuth2 Client - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-013
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cross-Site Request Forgery (CSRF) vulnerability in Drupal OAuth2 Client allows Cross Site Request Forgery.This issue affects OAuth2 Client: from 0.0.0 before 4.1.3.
CVSS 6.8 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
oauth2 client
- Versions
- ≥ 0.0.0, < 4.1.3: Affected (semver)
Update to 4.1.3
drupal/oauth2_client Packagist:https://packages.drupal.org/8
- Affected ranges
- ECOSYSTEM: < 4.1.3
Update to 4.1.3
drupal/oauth2_client Packagist
- Affected ranges
- ECOSYSTEM: < 4.1.3
Update to 4.1.3