CVE-2025-3887
CVE-2025-3887 · GStreamer H265 Codec Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GStreamer H265 Codec Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of H265 slice headers. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-26596.
CVSS 8.8 · High · EPSS 0.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gstreamer
- Versions
- 2e8b542145c1b11f8b8d927f6c679fd8028ceb60: Affected
No fix published
gst-plugins-bad1.0 Debian:12
- Versions
- 1.22.0-4
- 1.22.0-4+deb12u1
- 1.22.0-4+deb12u2
- 1.22.0-4+deb12u3
- 1.22.0-4+deb12u4
- 1.22.0-4+deb12u5
- Affected ranges
- ECOSYSTEM: < 1.22.0-4+deb12u6
Update to 1.22.0-4+deb12u6
gst-plugins-bad1.0 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.26.1-1
Update to 1.26.1-1
gst-plugins-bad1.0 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.26.1-1
Update to 1.26.1-1
gst-plugins-bad1.0 Ubuntu:Pro:16.04:LTS
- Versions
- 1.6.0-1ubuntu1
- 1.6.1-1ubuntu1
- 1.6.2-1ubuntu1
- 1.7.1-1ubuntu1
- 1.7.1-1ubuntu3
- 1.7.1-1ubuntu4
- 1.7.2-1ubuntu1
- 1.7.90-1ubuntu2
- 1.7.91-1ubuntu1
- 1.8.0-1ubuntu1
- 1.8.1-1ubuntu0.1
- 1.8.2-1ubuntu0.1
- 1.8.2-1ubuntu0.2
- 1.8.3-1ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 1.8.3-1ubuntu0.2+esm1
Update to 1.8.3-1ubuntu0.2+esm1
gst-plugins-bad1.0 Ubuntu:Pro:18.04:LTS
- Versions
- 1.12.3-1ubuntu1
- 1.12.3-1ubuntu2
- 1.12.3-2ubuntu1
- 1.12.4-2ubuntu1
- 1.12.4-2ubuntu2
- 1.13.1-1ubuntu1
- 1.13.91-1ubuntu1
- 1.14.0-1ubuntu1
- 1.14.1-1ubuntu1~ubuntu18.04.1
- 1.14.4-1ubuntu1~ubuntu18.04.1
- 1.14.5-0ubuntu1~18.04.1
- Affected ranges
- ECOSYSTEM: < 1.14.5-0ubuntu1~18.04.1+esm1
Update to 1.14.5-0ubuntu1~18.04.1+esm1
gst-plugins-bad1.0 Ubuntu:Pro:20.04:LTS
- Versions
- 1.16.1-1ubuntu1
- 1.16.1-1ubuntu3
- 1.16.1-1ubuntu4
- 1.16.1-1ubuntu5
- 1.16.1-1ubuntu6
- 1.16.1-1ubuntu8
- 1.16.2-1ubuntu1
- 1.16.2-1ubuntu2
- 1.16.2-2ubuntu1
- 1.16.2-2.1ubuntu1
- 1.16.3-0ubuntu1
- 1.16.3-0ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 1.16.3-0ubuntu1.1+esm1
Update to 1.16.3-0ubuntu1.1+esm1
gst-plugins-bad1.0 Ubuntu:Pro:22.04:LTS
- Versions
- 1.18.5-1ubuntu1
- 1.18.5-1ubuntu3
- 1.20.0-2ubuntu2
- 1.20.1-1ubuntu2
- 1.20.3-0ubuntu1
- 1.20.3-0ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 1.20.3-0ubuntu1.1+esm2
Update to 1.20.3-0ubuntu1.1+esm2
gst-plugins-bad1.0 Ubuntu:Pro:24.04:LTS
- Versions
- 1.22.4-1ubuntu1
- 1.22.4-1ubuntu2
- 1.22.4-1ubuntu4
- 1.22.9-2ubuntu1
- 1.24.0-1ubuntu3
- 1.24.0-1ubuntu4
- 1.24.2-1ubuntu4
- Affected ranges
- ECOSYSTEM: < 1.24.2-1ubuntu4+esm1
Update to 1.24.2-1ubuntu4+esm1