CVE-2025-4144
CVE-2025-4144 · PKCE bypass via downgrade attack
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PKCE was implemented in the OAuth implementation in workers-oauth-provider that is part of MCP framework https://github.com/cloudflare/workers-mcp . However, it was found that an attacker could cause the check to be skipped. Fixed in: https://github.com/cloudflare/workers-oauth-provider/pull/27 https://github.com/cloudflare/workers-oauth-provider/pull/27 Impact: PKCE is a defense-in-depth mechanism against certain kinds of attacks and was an optional extension in OAuth 2.0 which became required in the OAuth 2.1 draft. (Note that the MCP specification requires OAuth 2.1.). This bug completely bypasses PKCE protection.
CVSS 5.3 · Medium · EPSS 0.6% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
@cloudflare/workers-oauth-provider npm
- Affected ranges
- SEMVER: < 0.0.5
Update to 0.0.5