p PatchFirst

PatchFirst · Latest vulnerabilities

@cloudflare/workers-oauth-provider vulnerabilities

Vulnerabilities published for @cloudflare/workers-oauth-provider in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2025-4144

    Medium · CVSS 5.3EPSS 0.58%Fix available

    PKCE bypass via downgrade attack

    PKCE was implemented in the OAuth implementation in workers-oauth-provider that is part of MCP framework https://github.com/cloudflare/workers-mcp . However, it was found that an attacker could cause the check to be skipped. Fixed in: https://github.com/cloudflare/workers-oauth-provider/pull/27 https://github.com/cloudflare/workers-oauth-provider/pull/27 Impact: PKCE is a defense-in-depth mechanism against certain kinds of attacks and was an optional extension in OAuth 2.0 which became required in the OAuth 2.1 draft. (Note that the MCP specification requires OAuth 2.1.). This bug completely bypasses PKCE protection.

    • Update to 0.0.5
    Published Updated
  2. CVE-2025-4143

    Medium · CVSS 6EPSS 0.33%Fix available

    Missing validation of redirect_uri on authorize endpoint

    The OAuth implementation in workers-oauth-provider that is part of MCP framework https://github.com/cloudflare/workers-mcp , did not correctly validate that redirect_uri was on the allowed list of redirect URIs for the given client registration. Fixed in:  https://github.com/cloudflare/workers-oauth-provider/pull/26 https://github.com/cloudflare/workers-oauth-provider/pull/26 Impact: Under certain circumstances (see below), if a victim had previously authorized with a server built on workers-oath-provider, and an attacker could later trick the victim into visiting a malicious web site, then attacker could potentially steal the victim'

    • Update to 0.0.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →