p PatchFirst

CVE-2025-47219

CVE-2025-47219

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In GStreamer through 1.26.1, the isomp4 plugin's qtdemux_parse_trak function may read past the end of a heap buffer while parsing an MP4 file, possibly leading to information disclosure.

CVSS 8.1 · High · EPSS 0.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gst-plugins-good1.0 Debian:12

    Versions
    • 1.22.0-5
    • 1.22.0-5+deb12u1
    • 1.22.0-5+deb12u2
    Affected ranges
    • ECOSYSTEM: < 1.22.0-5+deb12u3

    Update to 1.22.0-5+deb12u3

  • gst-plugins-good1.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.26.2-1

    Update to 1.26.2-1

  • gst-plugins-good1.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.26.2-1

    Update to 1.26.2-1

  • gst-plugins-good1.0 Ubuntu:Pro:16.04:LTS

    Versions
    • 1.6.0-1ubuntu1
    • 1.6.1-1ubuntu1
    • 1.6.2-1ubuntu1
    • 1.7.1-1ubuntu1
    • 1.7.2-1ubuntu1
    • 1.7.90-1ubuntu1
    • 1.7.91-1ubuntu1
    • 1.8.0-1ubuntu1
    • 1.8.1-1ubuntu0.1
    • 1.8.2-1ubuntu0.1
    • 1.8.2-1ubuntu0.2
    • 1.8.2-1ubuntu0.3
    • 1.8.3-1ubuntu0.3
    • 1.8.3-1ubuntu0.4
    • 1.8.3-1ubuntu0.5
    • 1.8.3-1ubuntu0.5+esm1
    • 1.8.3-1ubuntu0.5+esm2
    • 1.8.3-1ubuntu0.5+esm3
    • 1.8.3-1ubuntu0.5+esm4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gst-plugins-good1.0 Ubuntu:Pro:18.04:LTS

    Versions
    • 1.12.3-1ubuntu1
    • 1.12.4-1ubuntu1
    • 1.13.1-1ubuntu1
    • 1.13.91-1ubuntu1
    • 1.14.0-1ubuntu1
    • 1.14.1-1ubuntu1~ubuntu18.04.1
    • 1.14.4-1ubuntu1~ubuntu18.04.1
    • 1.14.5-0ubuntu1~18.04.1
    • 1.14.5-0ubuntu1~18.04.2
    • 1.14.5-0ubuntu1~18.04.3
    Affected ranges
    • ECOSYSTEM: < 1.14.5-0ubuntu1~18.04.3+esm1

    Update to 1.14.5-0ubuntu1~18.04.3+esm1

  • gst-plugins-good1.0 Ubuntu:Pro:20.04:LTS

    Versions
    • 1.16.1-1ubuntu1
    • 1.16.2-1ubuntu1
    • 1.16.2-1ubuntu2
    • 1.16.2-1ubuntu2.1
    • 1.16.3-0ubuntu1
    • 1.16.3-0ubuntu1.1
    • 1.16.3-0ubuntu1.2
    • 1.16.3-0ubuntu1.3
    Affected ranges
    • ECOSYSTEM: < 1.16.3-0ubuntu1.3+esm1

    Update to 1.16.3-0ubuntu1.3+esm1

  • gst-plugins-good1.0 Ubuntu:22.04:LTS

    Versions
    • 1.18.5-1ubuntu2
    • 1.18.5-1ubuntu3
    • 1.20.0-2ubuntu1
    • 1.20.1-1ubuntu1
    • 1.20.3-0ubuntu1
    • 1.20.3-0ubuntu1.1
    • 1.20.3-0ubuntu1.3
    Affected ranges
    • ECOSYSTEM: < 1.20.3-0ubuntu1.4

    Update to 1.20.3-0ubuntu1.4

  • gst-plugins-good1.0 Ubuntu:24.04:LTS

    Versions
    • 1.22.6-1ubuntu1
    • 1.22.6-1ubuntu2
    • 1.22.8-3ubuntu1
    • 1.22.9-1ubuntu1
    • 1.24.0-1ubuntu5
    • 1.24.0-1ubuntu7
    • 1.24.1-2ubuntu1
    • 1.24.2-1ubuntu1
    • 1.24.2-1ubuntu1.1
    Affected ranges
    • ECOSYSTEM: < 1.24.2-1ubuntu1.2

    Update to 1.24.2-1ubuntu1.2

  • gst-plugins-good1.0 Ubuntu:25.10

    Versions
    • 1.26.0-1ubuntu2
    • 1.26.0-1ubuntu3
    Affected ranges
    • ECOSYSTEM: < 1.26.2-1ubuntu1

    Update to 1.26.2-1ubuntu1

Original sources

Check your server →