p PatchFirst

PatchFirst · Latest vulnerabilities

gst-plugins-good1.0 vulnerabilities

Vulnerabilities published for gst-plugins-good1.0 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 10

  1. CVE-2026-5056

    High · CVSS 7.8EPSS 0.34%Fix available

    GStreamer qtdemux Stack-based Buffer Overflow Remote Code Execution Vulnerability

    GStreamer qtdemux Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of UncompressedFrameConfigBox structures. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current p

    • Update to 1.26.5-1ubuntu2.2
    Published Updated
  2. CVE-2026-53705

    High · CVSS 7.6EPSS 0.38%No fix published

    Gstreamer1-plugins-good: gstreamer: heap buffer overflow in wavpack decoder via integer overflow

    A flaw was found in GStreamer's WavPack audio decoder in gst-plugins-good. When processing a specially crafted WavPack file, an integer overflow in the buffer size calculation (4 * block_samples * channels) in gst_wavpack_dec_handle_frame() causes a very small heap allocation. The WavPack library then writes decoded audio samples far beyond the allocated buffer, resulting in heap memory corruption. This affects both 32-bit and 64-bit systems since the arithmetic is performed in 32-bit integers before promotion to the allocation size type. A remote attacker could use this flaw to crash an application or potentially execute arbitrary code by co

    Published Updated
  3. CVE-2026-46470

    Medium · CVSS 4EPSS 0.21%Fix available

    CVE-2026-46470

    An issue was discovered in GStreamer gst-plugins-good before 1.28.2. When parsing MP4 audio tracks, the isomp4 plugin's qtdemux_audio_caps function does not sufficiently validate atom data before performing division operations, leading to denial of service due to integer division by zero.

    • Update to 1.26.5-1ubuntu2.3
    Published Updated
  4. CVE-2026-46469

    Medium · CVSS 4EPSS 0.1%Fix available

    CVE-2026-46469

    An issue was discovered in GStreamer gst-plugins-good before 1.28.2. When parsing MP4 audio tracks, the isomp4 plugin's qtdemux_parse_trak function does not sufficiently validate atom data before performing division operations, leading to denial of service due to integer division by zero.

    • Update to 1.26.5-1ubuntu2.3
    Published Updated
  5. CVE-2026-3083

    High · CVSS 8.8EPSS 0.82%Fix available

    GStreamer rtpqdm2depay Out-Of-Bounds Write Remote Code Execution Vulnerability

    GStreamer rtpqdm2depay Out-Of-Bounds Write Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the processing of X-QDM RTP payload elements. When parsing the packetid element, the process does not properly validate user-supplied data, which can result in a write past the end of an allocated array. An attacker can leverage this vulnerability to execute code in the context of the current p

    • Update to 1.26.5-1ubuntu2.1
    Published Updated
  6. CVE-2026-3085

    High · CVSS 8.8EPSS 1.31%Fix available

    GStreamer rtpqdm2depay Heap-based Buffer Overflow Remote Code Execution Vulnerability

    GStreamer rtpqdm2depay Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the processing of X-QDM RTP payloads. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a heap-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-28851.

    • Update to 1.26.5-1ubuntu2.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →