CVE-2025-48370
CVE-2025-48370 · auth-js Vulnerable to Insecure Path Routing from Malformed User Input
This page contains facts from public vulnerability sources. Check the original advisory before updating.
auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.70.0, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.70.0.
CVSS 2.7 · Low · EPSS 0.9% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
auth-js
- Versions
- < 2.70.0: Affected
No fix published
@supabase/auth-js npm
- Affected ranges
- SEMVER: < 2.70.0
Update to 2.70.0