p PatchFirst

PatchFirst · Latest vulnerabilities

@supabase/auth-js vulnerabilities

Vulnerabilities published for @supabase/auth-js in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2025-48370

    Low · CVSS 2.7EPSS 0.9%Fix available

    auth-js Vulnerable to Insecure Path Routing from Malformed User Input

    auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.70.0, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.70.0.

    • Update to 2.70.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →