p PatchFirst

CVE-2025-58048

CVE-2025-58048 · Paymenter Vulnerable to Remote Code Execution via Public File Uploads

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Paymenter is a free and open-source webshop solution for hostings. Prior to version 1.2.11, the ticket attachments functionality in Paymenter allows a malicious authenticated user to upload arbitrary files. This could result in sensitive data extraction from the database, credentials being read from configuration files, and arbitrary system commands being run under the web server user context. This vulnerability was patched by commit 87c3db4 and was released under the version 1.2.11 tag without any other code modifications compared to version 1.2.10. If upgrading is not immediately possible, administrators can mitigate this vulnerability with one or more of the following measures: updating nginx config to download attachments instead of executing them or disallowing access to /storage/ fully using a WAF such as Cloudflare.

CVSS 10.0 · Critical · EPSS 0.4% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • paymenter

    Versions
    • < 1.2.11: Affected

    No fix published

  • paymenter/paymenter Packagist

    Versions
    • 0.1
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2
    • 0.2.1
    • v0.3
    • v0.4
    • v0.4.1
    • v0.5
    • v0.5.1
    • v0.5.2
    • v0.5.3
    • v0.6
    • v0.7
    • v0.7.1
    • v0.8
    • v0.8.1
    • v0.8.2
    • v0.9
    • v0.9.1
    • v0.9.2
    • v0.9.3
    • v0.9.4
    • v0.9.5
    • v1.0.0
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v1.0.4
    • v1.1.0
    • v1.1.1
    Affected ranges
    • ECOSYSTEM: < 1.2.11

    Update to 1.2.11

Original sources

Check your server →