p PatchFirst

PatchFirst · Latest vulnerabilities

paymenter/paymenter vulnerabilities

Vulnerabilities published for paymenter/paymenter in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 7

  1. CVE-2026-71537

    Medium · CVSS 6.5EPSS 0.33%Fix available

    Paymenter: Credit-refund double-spend race condition in service downgrade (doUpgrade)

    Paymenter is a free and open-source webshop solution for management of hosting services. Prior to 1.5.7, app/Livewire/Services/Upgrade.php::doUpgrade() relies on Service::upgradable to check for a pending service upgrade and later executes $credit->increment('amount', abs($price)) without DB::transaction or lockForUpdate() spanning those operations. An authenticated customer with an active downgradable service can submit concurrent downgrade requests that each observe no pending upgrade, create separate upgrade records, and increment the same account credit balance, producing multiple spendable refunds for one downgrade. This issue is fixed i

    • Update to 1.5.7
    Published Updated
  2. CVE-2026-55219

    Medium · CVSS 5.3EPSS 0.21%Fix available

    Paymenter: Race condition in payWithCredit() enables credit double-spend

    Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.5, the credit payment implementation in app/Livewire/Invoices/Show.php executes a pessimistic row lock (lockForUpdate()) outside of an active database transaction. Because MySQL/MariaDB requires an enclosing transaction to enforce row-level locks, the guard is ineffective. Concurrent payment requests can exploit this race condition to read the same credit balance simultaneously, allowing users to pay multiple invoices using the same credit balance. In database systems like MySQL, a row lock only works inside a formal transaction;

    • Update to 1.5.5
    Published Updated
  3. CVE-2026-47198

    High · CVSS 8.5EPSS 0.4%Fix available

    Paymenter: URL parameter injection bypasses paid plan limits at checkout

    Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.1, the checkout component improperly filters URL-writable properties, allowing authenticated users to inject arbitrary key-value pairs into server provisioning parameters. Because bundled server extensions prioritize these user-supplied properties over administrator-defined configurations, a regular user can override hosting plans and resource limits at checkout without special privileges. The Checkout Livewire component's $checkoutConfig property exposed via URL query parameters, only validating keys explicitly defined by an exte

    • Update to 1.5.1
    Published Updated
  4. CVE-2026-44585

    Medium · CVSS 5.4EPSS 0.29%Fix available

    Paymenter: Broken object level authorization via service reference manipulation on ticket creation

    Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the ticket creation endpoint accepts a user-supplied service identifier without enforcing ownership validation, allowing authenticated users to create support tickets referencing services belonging to other accounts by modifying the service ID in the request. An attacker could modify the service ID value in the client-side request and successfully create a ticket associated with another user's service. The vulnerability requires authentication and does not provide direct access to service contents or customer data. However, ref

    • Update to 1.5.0
    Published Updated
  5. CVE-2026-44583

    Medium · CVSS 5.3EPSS 0.41%Fix available

    Paymenter: Blind Unauthenticated SSRF on the Paypal gateway module

    Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the PayPal webhook endpoint /extensions/paypal/webhook processes the PAYPAL-CERT-URL HTTP header without validation, allowing attackers to control server-side HTTP request destinations. This value is passed directly into a server-side HTTP request via file_get_contents, allowing attackers to control the destination of the request. No allowlist, validation, or signature verification is applied to the header before usage. As a result, the application can be coerced into performing HTTP requests to attacker-controlled or internal

    • Update to 1.5.0
    Published Updated
  6. CVE-2026-44584

    Medium · CVSS 4.3EPSS 0.16%Fix available

    Paymenter doesn't reset email verification status after email change

    Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the email update functionality fails to invalidate the existing verification state when a user changes their email address, allowing a verified account to retain its verified status after switching to an unverified or unowned email address. When a user updated their email address, the system did not reset or revalidate the associated email verification status. As a result, the verification column remained set to “true” even after the email address was changed. Exploitation could potentially result in: misrepresentation of email

    • Update to 1.5.0
    Published Updated
  7. CVE-2025-58048

    Critical · CVSS 10EPSS 0.41%Fix available

    Paymenter Vulnerable to Remote Code Execution via Public File Uploads

    Paymenter is a free and open-source webshop solution for hostings. Prior to version 1.2.11, the ticket attachments functionality in Paymenter allows a malicious authenticated user to upload arbitrary files. This could result in sensitive data extraction from the database, credentials being read from configuration files, and arbitrary system commands being run under the web server user context. This vulnerability was patched by commit 87c3db4 and was released under the version 1.2.11 tag without any other code modifications compared to version 1.2.10. If upgrading is not immediately possible, administrators can mitigate this vulnerability with

    • Update to 1.2.11
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →