p PatchFirst

CVE-2025-59940

CVE-2025-59940 · mkdocs-include-markdown-plugin susceptible to unvalidated input colliding with substitution placeholders

This page contains facts from public vulnerability sources. Check the original advisory before updating.

mkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin. In versions 7.1.7 and below, there is a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.

CVSS 6.5 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • mkdocs-include-markdown-plugin

    Versions
    • < 7.1.8: Affected

    No fix published

  • mkdocs-include-markdown-plugin PyPI

    Versions
    • 0.0.1
    • 0.0.2
    • 0.1.0
    • 1.0.0
    • 2.0.0
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.2.0
    • 2.3.0
    • 2.4.0
    • 2.5.0
    • 2.6.0
    • 2.6.1
    • 2.7.0
    • 2.7.1
    • 2.7.2
    • 2.8.0
    • 3.0.0
    • 3.0.1
    • 3.1.0
    • 3.1.1
    • 3.1.3
    • 3.1.4
    • 3.2.0
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.3.0
    • 3.4.0
    • 3.4.1
    • 3.5.0
    • 3.5.1
    • 3.5.2
    • 3.6.0
    • 3.6.1
    • 3.7.0
    • 3.7.1
    • 3.8.0
    • 3.8.1
    • 3.9.0
    • 3.9.1
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.0.3
    • 4.0.4
    • 5.0.0
    • 5.1.0
    • 6.0.0
    • 6.0.1
    • 6.0.2
    • 6.0.3
    • 6.0.4
    • 6.0.5
    • 6.0.6
    • 6.0.7
    • 6.1.0
    • 6.1.1
    • 6.2.0
    • 6.2.1
    • 6.2.2
    • 7.0.0
    • 7.0.1
    • 7.1.1
    • 7.1.2
    • 7.1.3
    • 7.1.4
    • 7.1.5
    • 7.1.6
    • 7.1.7
    Affected ranges
    • ECOSYSTEM: < 7.1.8

    Update to 7.1.8

Original sources

Check your server →