CVE-2025-71328
CVE-2025-71328 · Flowise - Unverified Password Change via Account Settings
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Flowise before 3.0.10 contains an unverified password change vulnerability. An authenticated user can change their account password through the account settings (Security) section without supplying the current password or any additional verification, as the application does not enforce a current-password check on the credential change. This can lead to full account takeover, particularly if an attacker can hijack or coerce an authenticated session.
CVSS 8.7 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
flowise
- Versions
- ≥ 0, < 3.0.10: Affected (semver)
- 3.0.10: Not affected (semver)
Update to 3.0.10
flowise-ui npm
- Affected ranges
- SEMVER: < 3.0.10
Update to 3.0.10