p PatchFirst

PatchFirst · Latest vulnerabilities

flowise-ui vulnerabilities

Vulnerabilities published for flowise-ui in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2025-71328

    High · CVSS 8.7EPSS 0.47%Fix available

    Flowise - Unverified Password Change via Account Settings

    Flowise before 3.0.10 contains an unverified password change vulnerability. An authenticated user can change their account password through the account settings (Security) section without supplying the current password or any additional verification, as the application does not enforce a current-password check on the credential change. This can lead to full account takeover, particularly if an attacker can hijack or coerce an authenticated session.

    • Update to 3.0.10
    Published Updated
  2. CVE-2025-71337

    High · CVSS 8.7EPSS 0.42%Fix available

    Flowise - Unverified Email Change via Account Profile Endpoint

    Flowise before 3.0.10 (affected versions 3.0.7 and earlier) contains an unverified email change vulnerability. An authenticated user can change the account email address, used as a login identifier and password-recovery channel, via the account profile endpoint without confirming the change to the original email address or re-entering the current password. By changing the recovery email, an attacker can take over the account and abuse password reset mechanisms.

    • Update to 3.0.10
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →