CVE-2026-0824
CVE-2026-0824 · questdb ui Web Console cross site scripting
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A security flaw has been discovered in questdb ui up to 1.11.9. Impacted is an unknown function of the component Web Console. The manipulation results in cross site scripting. The attack can be executed remotely. The exploit has been released to the public and may be used for attacks. Upgrading to version 1.1.10 is recommended to address this issue. The patch is identified as b42fd9f18476d844ae181a10a249e003dafb823d. You should upgrade the affected component. The vendor confirmed early that the fix "is going to be released as a part of QuestDB 9.3.0" as well.
CVSS 5.1 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
ui
- Versions
- 1.11.0: Affected
- 1.11.1: Affected
- 1.11.2: Affected
- 1.11.3: Affected
- 1.11.4: Affected
- 1.11.5: Affected
- 1.11.6: Affected
- 1.11.7: Affected
- 1.11.8: Affected
- 1.11.9: Affected
- 1.1.10: Not affected
No fix published
@questdb/web-console npm
- Affected ranges
- SEMVER: < 1.1.10
Update to 1.1.10
Original sources
- https://vuldb.com/?id.340357
- https://vuldb.com/?ctiid.340357
- https://vuldb.com/?submit.733253
- https://github.com/59lab/dbdb/blob/main/There%20is%20a%20cross-site%20scripting(XSS)%20vulnerability%20in%20the%20QuestDB%20database.md
- https://github.com/questdb/questdb/releases/tag/9.3.0
- https://github.com/questdb/ui/pull/519#issue-3790862030
- https://github.com/questdb/ui/commit/b42fd9f18476d844ae181a10a249e003dafb823d
- https://github.com/questdb/ui/pull/518
- https://github.com/questdb/ui/
- https://nvd.nist.gov/vuln/detail/CVE-2026-0824