CVE-2026-106491
CVE-2026-106491 · Backstage: Improper input validation in proxy-backend
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Backstage is an open framework for building developer portals. Prior to 0.6.17, the @backstage/plugin-proxy-backend package is affected by improper input validation in proxy-backend. An authenticated Backstage user could craft a request URL that causes the proxy-backend to forward the request to a path outside the configured base path on the target server. This is limited to target servers already configured as proxy endpoints and requires Backstage authentication by default. This issue is fixed in version 0.6.17.
CVSS 6.4 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
backstage
- Versions
- < 1.54.6: Affected
No fix published
plugin-proxy-backend
- Versions
- < 0.6.17: Affected
No fix published
@backstage/plugin-proxy-backend npm
- Affected ranges
- SEMVER: < 0.6.17
Update to 0.6.17