p PatchFirst

CVE-2026-11572

CVE-2026-11572

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions of the package degit before 2.8.6, from 3.0.0 and before 3.3.1 are vulnerable to Command Injection due to improper sanitisation of user input for git shell commands directly invoked with exec() method by _cloneWithGit() and fetchRefs() functions. An attacker can execute arbitrary operating system commands as the process user by supplying a specially crafted git repository name.

CVSS 8.7 · High · EPSS 1.0% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • degit

    Versions
    • ≥ 0, < 2.8.6: Affected (semver)
    • ≥ 3.0.0, < 3.3.1: Affected (semver)

    Update to 2.8.6; Update to 3.3.1

  • degit npm

    Affected ranges
    • SEMVER: < 2.8.6

    Update to 2.8.6

  • degit npm

    Affected ranges
    • SEMVER: ≥ 3.0.0, < 3.3.1

    Update to 3.3.1

Original sources

Check your server →