p PatchFirst

PatchFirst · Latest vulnerabilities

degit vulnerabilities

Vulnerabilities published for degit in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-11572

    High · CVSS 8.7EPSS 1.04%Fix available

    CVE-2026-11572

    Versions of the package degit before 2.8.6, from 3.0.0 and before 3.3.1 are vulnerable to Command Injection due to improper sanitisation of user input for git shell commands directly invoked with exec() method by _cloneWithGit() and fetchRefs() functions. An attacker can execute arbitrary operating system commands as the process user by supplying a specially crafted git repository name.

    • Update to 2.8.6
    • Update to 3.3.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →