CVE-2026-1217
CVE-2026-1217 · Yoast Duplicate Post <= 4.5 - Authenticated (Contributor+) Missing Authorization to Arbitrary Post Duplication and Overwrite
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The Yoast Duplicate Post plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the clone_bulk_action_handler() and republish_request() functions in all versions up to, and including, 4.5. This makes it possible for authenticated attackers, with Contributor-level access and above, to duplicate any post on the site including private, draft, and trashed posts they shouldn't have access to. Additionally, attackers with Author-level access and above can use the Rewrite & Republish feature to overwrite any published post with their own content.
CVSS 5.4 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
yoast duplicate post
- Versions
- ≥ 0, ≤ 4.5: Affected (semver)
No fix published
yoast/duplicate-post Packagist
- Versions
- 4.1.2
- 4.2
- 4.2-RC1
- 4.3
- 4.3-RC1
- 4.4
- 4.4-RC1
- 4.4-RC2
- 4.4-RC3
- 4.5
- 4.5-RC1
- 4.6-RC1
- 4.6-RC2
- Affected ranges
- ECOSYSTEM: < 4.6
Update to 4.6
Original sources
- https://www.wordfence.com/threat-intel/vulnerabilities/id/05f175e6-08a9-4199-948c-5bd8b3caaa39?source=cve
- https://plugins.trac.wordpress.org/browser/duplicate-post/tags/4.5/src/handlers/bulk-handler.php#L115
- https://plugins.trac.wordpress.org/browser/duplicate-post/tags/4.5/src/post-republisher.php#L128
- https://nvd.nist.gov/vuln/detail/CVE-2026-1217