p PatchFirst

CVE-2026-25554

CVE-2026-25554 · OpenSIPS 3.1 <= 3.6.4 auth_jwt SQL Injection Enables JWT Authentication Bypass

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenSIPS versions 3.1 before 3.6.4 containing the auth_jwt module (prior to commit 3822d33) contain a SQL injection vulnerability in the jwt_db_authorize() function in modules/auth_jwt/authorize.c when db_mode is enabled and a SQL database backend is used. The function extracts the tag claim from a JWT without prior signature verification and incorporates the unescaped value directly into a SQL query. An attacker can supply a crafted JWT with a malicious tag claim to manipulate the query result and bypass JWT authentication, allowing impersonation of arbitrary identities.

CVSS 8.3 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • opensips

    Versions
    • ≥ 3.1, < 3.6.4: Affected (custom)

    Update to 3.6.4

  • opensips Ubuntu:18.04:LTS

    Versions
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →