CVE-2026-25957
CVE-2026-25957 · Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
CVSS 6.5 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
cube
- Versions
- >= 1.1.17, < 1.4.2: Affected
- >= 1.5.0, < 1.5.13: Affected
No fix published
@cubejs-backend/server-core npm
- Affected ranges
- SEMVER: ≥ 1.1.17, < 1.4.2
Update to 1.4.2
@cubejs-backend/server-core npm
- Affected ranges
- SEMVER: ≥ 1.5.0, < 1.5.13
Update to 1.5.13