CVE-2026-2922
CVE-2026-2922 · GStreamer RealMedia Demuxer Out-Of-Bounds Write Remote Code Execution Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GStreamer RealMedia Demuxer Out-Of-Bounds Write Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the processing of video packets. The issue results from the lack of proper validation of user-supplied data, which can result in a write past the end of an allocated buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-28845.
CVSS 7.8 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gstreamer
- Versions
- 1c6e163aa33962f5ee4a87d29319ccdd5cb67612: Affected
No fix published
gst-plugins-ugly1.0 Debian:12
- Versions
- 1.22.0-2
- 1.22.0-2+deb12u1
- Affected ranges
- ECOSYSTEM: < 1.22.0-2+deb12u2
Update to 1.22.0-2+deb12u2
gst-plugins-ugly1.0 Debian:13
- Versions
- 1.26.3-4
- Affected ranges
- ECOSYSTEM: < 1.26.3-4+deb13u1
Update to 1.26.3-4+deb13u1
gst-plugins-ugly1.0 Debian:14
- Versions
- 1.26.10-1
- 1.26.3-4
- 1.26.4-1
- 1.26.5-1
- 1.26.5-2
- 1.26.6-1
- 1.26.7-1
- 1.26.8-1
- 1.26.9-1
- 1.27.1-1
- 1.27.2-1
- 1.27.50-1
- 1.27.50-2
- 1.27.90-1
- 1.28.0-1
- Affected ranges
- ECOSYSTEM: < 1.28.1-1
Update to 1.28.1-1
gst-plugins-ugly1.0 Ubuntu:Pro:16.04:LTS
- Versions
- 1.6.0-1ubuntu1
- 1.6.1-1ubuntu1
- 1.6.2-1ubuntu1
- 1.7.1-1ubuntu1
- 1.7.2-1ubuntu1
- 1.7.90-1ubuntu1
- 1.7.91-1ubuntu1
- 1.8.0-1ubuntu1
- 1.8.1-1ubuntu0.1
- 1.8.2-1ubuntu0.1
- 1.8.3-1ubuntu0.1
- 1.8.3-1ubuntu0.1+esm1
- Affected ranges
- ECOSYSTEM: < 1.8.3-1ubuntu0.1+esm2
Update to 1.8.3-1ubuntu0.1+esm2
gst-plugins-ugly1.0 Ubuntu:Pro:18.04:LTS
- Versions
- 1.12.3-1
- 1.12.3-1build1
- 1.12.4-1
- 1.12.4-1build1
- 1.13.1-1
- 1.13.91-1
- 1.14.0-1
- 1.14.1-1~ubuntu18.04.1
- 1.14.4-1~ubuntu18.04.1
- 1.14.5-0ubuntu1~18.04.1
- Affected ranges
- ECOSYSTEM: < 1.14.5-0ubuntu1~18.04.1+esm1
Update to 1.14.5-0ubuntu1~18.04.1+esm1
gst-plugins-ugly1.0 Ubuntu:Pro:20.04:LTS
- Versions
- 1.16.1-1
- 1.16.1-1build1
- 1.16.2-1
- 1.16.2-2
- 1.16.2-2build1
- Affected ranges
- ECOSYSTEM: < 1.16.2-2ubuntu0.1~esm1
Update to 1.16.2-2ubuntu0.1~esm1
gst-plugins-ugly1.0 Ubuntu:Pro:22.04:LTS
- Versions
- 1.18.5-1
- 1.20.0-1
- 1.20.0-1build1
- 1.20.1-1
- Affected ranges
- ECOSYSTEM: < 1.20.1-1ubuntu0.1~esm1
Update to 1.20.1-1ubuntu0.1~esm1
gst-plugins-ugly1.0 Ubuntu:Pro:24.04:LTS
- Versions
- 1.22.5-1
- 1.22.6-1
- 1.22.7-1
- 1.22.8-1
- 1.22.10-1
- 1.24.1-1
- 1.24.1-1build1
- Affected ranges
- ECOSYSTEM: < 1.24.1-1ubuntu0.1~esm1
Update to 1.24.1-1ubuntu0.1~esm1
gst-plugins-ugly1.0 Ubuntu:25.10
- Versions
- 1.26.0-1
- 1.26.1-1
- 1.26.2-1
- 1.26.3-1
- 1.26.3-3
- 1.26.3-4
- 1.26.4-1
- 1.26.5-1
- 1.26.6-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.zerodayinitiative.com/advisories/ZDI-26-165/
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/commit/88df8d2cd063b95a076e8041b47f778a4402f363
- https://access.redhat.com/security/cve/CVE-2026-2922
- https://bugzilla.redhat.com/show_bug.cgi?id=2447500
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-2922.json
- https://access.redhat.com/errata/RHSA-2026:8854
- https://access.redhat.com/errata/RHSA-2026:6259
- https://access.redhat.com/errata/RHSA-2026:19024
- https://access.redhat.com/errata/RHSA-2026:8862
- https://access.redhat.com/errata/RHSA-2026:6300
- https://access.redhat.com/errata/RHSA-2026:19180
- https://nvd.nist.gov/vuln/detail/CVE-2026-2922