p PatchFirst

CVE-2026-3085

CVE-2026-3085 · GStreamer rtpqdm2depay Heap-based Buffer Overflow Remote Code Execution Vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GStreamer rtpqdm2depay Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the processing of X-QDM RTP payloads. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a heap-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-28851.

CVSS 8.8 · High · EPSS 1.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gstreamer

    Versions
    • 1c6e163aa33962f5ee4a87d29319ccdd5cb67612: Affected

    No fix published

  • gst-plugins-good1.0 Debian:12

    Versions
    • 1.22.0-5
    • 1.22.0-5+deb12u1
    • 1.22.0-5+deb12u2
    • 1.22.0-5+deb12u3
    Affected ranges
    • ECOSYSTEM: < 1.22.0-5+deb12u4

    Update to 1.22.0-5+deb12u4

  • gst-plugins-good1.0 Debian:13

    Versions
    • 1.26.2-1
    • 1.26.2-1+deb13u1
    Affected ranges
    • ECOSYSTEM: < 1.26.2-1+deb13u2

    Update to 1.26.2-1+deb13u2

  • gst-plugins-good1.0 Debian:14

    Versions
    • 1.26.10-1
    • 1.26.2-1
    • 1.26.3-1
    • 1.26.4-1
    • 1.26.5-1
    • 1.26.5-2
    • 1.26.5-2+hurd.1
    • 1.26.5-3
    • 1.26.6-1
    • 1.26.7-1
    • 1.26.8-1
    • 1.26.9-1
    • 1.27.1-1
    • 1.27.2-1
    • 1.27.50-1
    • 1.27.50-2
    • 1.27.90-1
    • 1.28.0-1
    Affected ranges
    • ECOSYSTEM: < 1.28.1-1

    Update to 1.28.1-1

  • gst-plugins-good1.0 Ubuntu:Pro:16.04:LTS

    Versions
    • 1.6.0-1ubuntu1
    • 1.6.1-1ubuntu1
    • 1.6.2-1ubuntu1
    • 1.7.1-1ubuntu1
    • 1.7.2-1ubuntu1
    • 1.7.90-1ubuntu1
    • 1.7.91-1ubuntu1
    • 1.8.0-1ubuntu1
    • 1.8.1-1ubuntu0.1
    • 1.8.2-1ubuntu0.1
    • 1.8.2-1ubuntu0.2
    • 1.8.2-1ubuntu0.3
    • 1.8.3-1ubuntu0.3
    • 1.8.3-1ubuntu0.4
    • 1.8.3-1ubuntu0.5
    • 1.8.3-1ubuntu0.5+esm1
    • 1.8.3-1ubuntu0.5+esm2
    • 1.8.3-1ubuntu0.5+esm3
    • 1.8.3-1ubuntu0.5+esm4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gst-plugins-good1.0 Ubuntu:Pro:18.04:LTS

    Versions
    • 1.12.3-1ubuntu1
    • 1.12.4-1ubuntu1
    • 1.13.1-1ubuntu1
    • 1.13.91-1ubuntu1
    • 1.14.0-1ubuntu1
    • 1.14.1-1ubuntu1~ubuntu18.04.1
    • 1.14.4-1ubuntu1~ubuntu18.04.1
    • 1.14.5-0ubuntu1~18.04.1
    • 1.14.5-0ubuntu1~18.04.2
    • 1.14.5-0ubuntu1~18.04.3
    • 1.14.5-0ubuntu1~18.04.3+esm1
    • 1.14.5-0ubuntu1~18.04.3+esm2
    • 1.14.5-0ubuntu1~18.04.3+esm3
    • 1.14.5-0ubuntu1~18.04.3+esm4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gst-plugins-good1.0 Ubuntu:Pro:20.04:LTS

    Versions
    • 1.16.1-1ubuntu1
    • 1.16.2-1ubuntu1
    • 1.16.2-1ubuntu2
    • 1.16.2-1ubuntu2.1
    • 1.16.3-0ubuntu1
    • 1.16.3-0ubuntu1.1
    • 1.16.3-0ubuntu1.2
    • 1.16.3-0ubuntu1.3
    • 1.16.3-0ubuntu1.3+esm1
    • 1.16.3-0ubuntu1.3+esm2
    • 1.16.3-0ubuntu1.3+esm3
    • 1.16.3-0ubuntu1.3+esm4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gst-plugins-good1.0 Ubuntu:22.04:LTS

    Versions
    • 1.18.5-1ubuntu2
    • 1.18.5-1ubuntu3
    • 1.20.0-2ubuntu1
    • 1.20.1-1ubuntu1
    • 1.20.3-0ubuntu1
    • 1.20.3-0ubuntu1.1
    • 1.20.3-0ubuntu1.3
    • 1.20.3-0ubuntu1.4
    Affected ranges
    • ECOSYSTEM: < 1.20.3-0ubuntu1.5

    Update to 1.20.3-0ubuntu1.5

  • gst-plugins-good1.0 Ubuntu:24.04:LTS

    Versions
    • 1.22.6-1ubuntu1
    • 1.22.6-1ubuntu2
    • 1.22.8-3ubuntu1
    • 1.22.9-1ubuntu1
    • 1.24.0-1ubuntu5
    • 1.24.0-1ubuntu7
    • 1.24.1-2ubuntu1
    • 1.24.2-1ubuntu1
    • 1.24.2-1ubuntu1.1
    • 1.24.2-1ubuntu1.2
    Affected ranges
    • ECOSYSTEM: < 1.24.2-1ubuntu1.3

    Update to 1.24.2-1ubuntu1.3

  • gst-plugins-good1.0 Ubuntu:25.10

    Versions
    • 1.26.0-1ubuntu2
    • 1.26.0-1ubuntu3
    • 1.26.2-1ubuntu1
    • 1.26.4-1ubuntu1
    • 1.26.5-1ubuntu1
    • 1.26.5-1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 1.26.5-1ubuntu2.1

    Update to 1.26.5-1ubuntu2.1

Original sources

Check your server →