p PatchFirst

CVE-2026-30922

CVE-2026-30922 · pyasn1 Vulnerable to Denial of Service via Unbounded Recursion

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.3, the `pyasn1` library is vulnerable to a Denial of Service (DoS) attack caused by uncontrolled recursion when decoding ASN.1 data with deeply nested structures. An attacker can supply a crafted payload containing thousands of nested `SEQUENCE` (`0x30`) or `SET` (`0x31`) tags with "Indefinite Length" (`0x80`) markers. This forces the decoder to recursively call itself until the Python interpreter crashes with a `RecursionError` or consumes all available memory (OOM), crashing the host application. This is a distinct vulnerability from CVE-2026-23490 (which addressed integer overflows in OID decoding). The fix for CVE-2026-23490 (`MAX_OID_ARC_CONTINUATION_OCTETS`) does not mitigate this recursion issue. Version 0.6.3 fixes this specific issue.

CVSS 7.5 · High · EPSS 0.8% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • pyasn1

    Versions
    • < 0.6.3: Affected

    No fix published

  • pyasn1 Debian:12

    Versions
    • 0.4.8-3
    • 0.4.8-3+deb12u1
    Affected ranges
    • ECOSYSTEM: < 0.4.8-3+deb12u2

    Update to 0.4.8-3+deb12u2

  • pyasn1 Debian:13

    Versions
    • 0.6.1-1
    • 0.6.1-1+deb13u1
    Affected ranges
    • ECOSYSTEM: < 0.6.1-1+deb13u2

    Update to 0.6.1-1+deb13u2

  • pyasn1 Debian:14

    Versions
    • 0.6.1-1
    • 0.6.2-1
    • 0.6.2-1~bpo13+1
    Affected ranges
    • ECOSYSTEM: < 0.6.3-1

    Update to 0.6.3-1

  • pyasn1 PyPI

    Versions
    • 0.0.10a
    • 0.0.11a
    • 0.0.12a
    • 0.0.13
    • 0.0.13a
    • 0.0.13b
    • 0.0.6a
    • 0.0.9a
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.1.5
    • 0.1.6
    • 0.1.7
    • 0.1.8
    • 0.1.9
    • 0.2.1
    • 0.2.2
    • 0.2.3
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    • 0.3.6
    • 0.3.7
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • 0.4.4
    • 0.4.5
    • 0.4.6
    • 0.4.7
    • 0.4.8
    • 0.5.0
    • 0.5.1
    • 0.6.0
    • 0.6.1
    • 0.6.2
    Affected ranges
    • ECOSYSTEM: < 0.6.3

    Update to 0.6.3

  • pyasn1 Ubuntu:Pro:14.04:LTS

    Versions
    • 0.1.4-0ubuntu1
    • 0.1.7-1ubuntu1
    • 0.1.7-1ubuntu2
    • 0.1.7-1ubuntu2.1
    Affected ranges
    • ECOSYSTEM: < 0.1.7-1ubuntu2.1+esm1

    Update to 0.1.7-1ubuntu2.1+esm1

  • pyasn1 Ubuntu:Pro:16.04:LTS

    Versions
    • 0.1.8-2
    • 0.1.9-1
    Affected ranges
    • ECOSYSTEM: < 0.1.9-1ubuntu0.1~esm1

    Update to 0.1.9-1ubuntu0.1~esm1

  • pyasn1 Ubuntu:Pro:18.04:LTS

    Versions
    • 0.1.9-2
    • 0.4.2-3
    Affected ranges
    • ECOSYSTEM: < 0.4.2-3ubuntu0.18.04.1~esm1

    Update to 0.4.2-3ubuntu0.18.04.1~esm1

  • pyasn1 Ubuntu:Pro:20.04:LTS

    Versions
    • 0.4.2-3
    • 0.4.2-3build1
    Affected ranges
    • ECOSYSTEM: < 0.4.2-3ubuntu0.20.04.1~esm1

    Update to 0.4.2-3ubuntu0.20.04.1~esm1

  • pyasn1 Ubuntu:22.04:LTS

    Versions
    • 0.4.8-1
    • 0.4.8-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 0.4.8-1ubuntu0.2

    Update to 0.4.8-1ubuntu0.2

  • pyasn1 Ubuntu:24.04:LTS

    Versions
    • 0.4.8-4
    • 0.4.8-4ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 0.4.8-4ubuntu0.2

    Update to 0.4.8-4ubuntu0.2

  • pyasn1 Ubuntu:25.10

    Versions
    • 0.6.1-1
    • 0.6.1-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 0.6.1-1ubuntu0.2

    Update to 0.6.1-1ubuntu0.2

Original sources

Check your server →