p PatchFirst

PatchFirst · Latest vulnerabilities

pyasn1 vulnerabilities

Vulnerabilities published for pyasn1 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-30922

    High · CVSS 7.5EPSS 0.82%Fix available

    pyasn1 Vulnerable to Denial of Service via Unbounded Recursion

    pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.3, the `pyasn1` library is vulnerable to a Denial of Service (DoS) attack caused by uncontrolled recursion when decoding ASN.1 data with deeply nested structures. An attacker can supply a crafted payload containing thousands of nested `SEQUENCE` (`0x30`) or `SET` (`0x31`) tags with "Indefinite Length" (`0x80`) markers. This forces the decoder to recursively call itself until the Python interpreter crashes with a `RecursionError` or consumes all available memory (OOM), crashing the host application. This is a distinct vulnerability from CVE-2026-23490 (which addressed integer overflows

    • Update to 0.6.1-1ubuntu0.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →