CVE-2026-39397
CVE-2026-39397 · @delmaredigital/payload-puc is missing authorization on /api/puck/* CRUD endpoints allows unauthenticated access to Puck-registered collections
This page contains facts from public vulnerability sources. Check the original advisory before updating.
@delmaredigital/payload-puck is a PayloadCMS plugin for integrating Puck visual page builder. Prior to 0.6.23, all /api/puck/* CRUD endpoint handlers registered by createPuckPlugin() called Payload's local API with the default overrideAccess: true, bypassing all collection-level access control. The access option passed to createPuckPlugin() and any access rules defined on Puck-registered collections were silently ignored on these endpoints. This vulnerability is fixed in 0.6.23.
CVSS 9.4 · Critical · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
payload-puck
- Versions
- < 0.6.23: Affected
No fix published
@delmaredigital/payload-puck npm
- Affected ranges
- SEMVER: < 0.6.23
Update to 0.6.23