p PatchFirst

PatchFirst · Latest vulnerabilities

@delmaredigital/payload-puck vulnerabilities

Vulnerabilities published for @delmaredigital/payload-puck in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-39397

    Critical · CVSS 9.4EPSS 0.38%Fix available

    @delmaredigital/payload-puc is missing authorization on /api/puck/* CRUD endpoints allows unauthenticated access to Puck-registered collections

    @delmaredigital/payload-puck is a PayloadCMS plugin for integrating Puck visual page builder. Prior to 0.6.23, all /api/puck/* CRUD endpoint handlers registered by createPuckPlugin() called Payload's local API with the default overrideAccess: true, bypassing all collection-level access control. The access option passed to createPuckPlugin() and any access rules defined on Puck-registered collections were silently ignored on these endpoints. This vulnerability is fixed in 0.6.23.

    • Update to 0.6.23
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →