p PatchFirst

CVE-2026-42076

CVE-2026-42076 · Evolver: Command Injection via `execSync` in `_extractLLM()` function allows Remote Code Execution

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Evolver is a GEP-powered self-evolving engine for AI agents. Prior to version 1.69.3, a command injection vulnerability in the _extractLLM() function allows attackers to execute arbitrary shell commands on the server. The function constructs a curl command using string concatenation and passes it to execSync() without proper sanitization, enabling remote code execution when the corpus parameter contains shell metacharacters. This issue has been patched in version 1.69.3.

CVSS 9.8 · Critical · EPSS 1.7% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • evolver

    Versions
    • < 1.69.3: Affected

    No fix published

  • @evomap/evolver npm

    Affected ranges
    • SEMVER: < 1.69.3

    Update to 1.69.3

Original sources

Check your server →