CVE-2026-42843
CVE-2026-42843 · grav-plugin-api: Grav API Privilege Escalation to Super Admin
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Grav API Plugin is a RESTful API for Grav CMS that provides full headless access to your site's content, media, configuration, users, and system management. Prior to 1.0.0-beta.15, an insecure direct object reference and logic flaw in the Grav API plugin (UsersController::update) allows any authenticated user with basic API access (api.access) to modify their own permission configuration. An attacker can exploit this to escalate their privileges to Super Administrator (admin.super and api.super), leading to full system compromise and potential RCE. This vulnerability is fixed in 1.0.0-beta.15.
CVSS 8.8 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
grav-plugin-api
- Versions
- < 1.0.0-beta.15: Affected
No fix published
getgrav/grav-plugin-api Packagist
- Affected ranges
- ECOSYSTEM: < 1.0.0-beta.15
Update to 1.0.0-beta.15