p PatchFirst

PatchFirst · Latest vulnerabilities

getgrav/grav-plugin-api vulnerabilities

Vulnerabilities published for getgrav/grav-plugin-api in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-42843

    High · CVSS 8.8EPSS 0.35%Fix available

    grav-plugin-api: Grav API Privilege Escalation to Super Admin

    Grav API Plugin is a RESTful API for Grav CMS that provides full headless access to your site's content, media, configuration, users, and system management. Prior to 1.0.0-beta.15, an insecure direct object reference and logic flaw in the Grav API plugin (UsersController::update) allows any authenticated user with basic API access (api.access) to modify their own permission configuration. An attacker can exploit this to escalate their privileges to Super Administrator (admin.super and api.super), leading to full system compromise and potential RCE. This vulnerability is fixed in 1.0.0-beta.15.

    • Update to 1.0.0-beta.15
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →