p PatchFirst

CVE-2026-43945

CVE-2026-43945 · FUXA Vulnerable to Pre-auth RCE via Path Manipulation & Configuration Injection

This page contains facts from public vulnerability sources. Check the original advisory before updating.

FUXA is a web-based Process Visualization (SCADA/HMI/Dashboard) software. Versions 1.2.11 until 1.3.1 allow an unauthenticated remote attacker to achieve Full Remote Code Execution (RCE) as root. The exploit succeeds even when the platform is configured in its most secure state (Secure Mode Enabled and Node-RED Secure Auth Enabled). Version 1.3.1 fixes the issue.

CVSS 8.9 · High · EPSS 0.8% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • fuxa

    Versions
    • >= 1.2.11, < 1.3.1: Affected

    No fix published

  • @frangoteam/fuxa npm

    Affected ranges
    • SEMVER: ≥ 1.2.11, < 1.3.1

    Update to 1.3.1

Original sources

Check your server →