p PatchFirst

PatchFirst · Latest vulnerabilities

@frangoteam/fuxa vulnerabilities

Vulnerabilities published for @frangoteam/fuxa in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 6

  1. CVE-2026-43945

    High · CVSS 8.9EPSS 0.84%Fix available

    FUXA Vulnerable to Pre-auth RCE via Path Manipulation & Configuration Injection

    FUXA is a web-based Process Visualization (SCADA/HMI/Dashboard) software. Versions 1.2.11 until 1.3.1 allow an unauthenticated remote attacker to achieve Full Remote Code Execution (RCE) as root. The exploit succeeds even when the platform is configured in its most secure state (Secure Mode Enabled and Node-RED Secure Auth Enabled). Version 1.3.1 fixes the issue.

    • Update to 1.3.1
    Published Updated
  2. CVE-2025-69985

    Critical · CVSS 9.8EPSS 5.97%Public exploitNo fix published

    CVE-2025-69985

    FUXA 1.2.8 and prior contains an Authentication Bypass vulnerability leading to Remote Code Execution (RCE). The vulnerability exists in the server/api/jwt-helper.js middleware, which improperly trusts the HTTP "Referer" header to validate internal requests. A remote unauthenticated attacker can bypass JWT authentication by spoofing the Referer header to match the server's host. Successful exploitation allows the attacker to access the protected /api/runscript endpoint and execute arbitrary Node.js code on the server.

    Published Updated
  3. CVE-2025-69971

    Critical · CVSS 9.8EPSS 2.17%Public exploitFix available

    CVE-2025-69971

    FUXA v1.2.7 contains a hard-coded credential vulnerability in server/api/jwt-helper.js. The application uses a hard-coded secret key to sign and verify JWT Tokens. This allows remote attackers to forge valid admin tokens and bypass authentication to gain full administrative access.

    • Update to 1.3.0
    Published Updated
  4. CVE-2021-45851

    High · CVSS 7.5EPSS 1.45%No fix published

    CVE-2021-45851

    A Server-Side Request Forgery (SSRF) attack in FUXA 1.1.3 can be carried out leading to the obtaining of sensitive information from the server's internal environment and services, often potentially leading to the attacker executing commands on the server.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →