p PatchFirst

CVE-2026-44585

CVE-2026-44585 · Paymenter: Broken object level authorization via service reference manipulation on ticket creation

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the ticket creation endpoint accepts a user-supplied service identifier without enforcing ownership validation, allowing authenticated users to create support tickets referencing services belonging to other accounts by modifying the service ID in the request. An attacker could modify the service ID value in the client-side request and successfully create a ticket associated with another user's service. The vulnerability requires authentication and does not provide direct access to service contents or customer data. However, referenced service information could become visible to support personnel handling the ticket. Successful exploitation could allow an authenticated user to: create support tickets referencing services belonging to other users, potentially cause support staff to interact with or review unrelated customer services. The vulnerability did not allow direct access to another user's service, modification of another user's service or retrieval of confidential service data through the vulnerable endpoint itself. This issue has been fixed in version 1.5.0.

CVSS 5.4 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • paymenter

    Versions
    • < 1.5.0: Affected

    No fix published

  • paymenter/paymenter Packagist

    Versions
    • 0.1
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2
    • 0.2.1
    • v0.3
    • v0.4
    • v0.4.1
    • v0.5
    • v0.5.1
    • v0.5.2
    • v0.5.3
    • v0.6
    • v0.7
    • v0.7.1
    • v0.8
    • v0.8.1
    • v0.8.2
    • v0.9
    • v0.9.1
    • v0.9.2
    • v0.9.3
    • v0.9.4
    • v0.9.5
    • v1.0.0
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v1.0.4
    • v1.1.0
    • v1.1.1
    Affected ranges
    • ECOSYSTEM: < 1.5.0

    Update to 1.5.0

Original sources

Check your server →