CVE-2026-45802
CVE-2026-45802 · FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service
This page contains facts from public vulnerability sources. Check the original advisory before updating.
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.
CVSS 6.0 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
fpdi
- Versions
- < 2.6.7: Affected
No fix published
setasign/fpdi Packagist
- Versions
- 1.5.2
- 1.5.3
- 1.5.4
- 1.6.0
- 1.6.1
- 1.6.2
- v2.0.0
- v2.0.0-beta
- v2.0.0-beta2
- v2.0.0-rc1
- v2.0.1
- v2.0.2
- v2.0.3
- v2.1.0
- v2.1.1
- v2.2.0
- v2.3.0
- v2.3.1
- v2.3.2
- v2.3.3
- v2.3.4
- v2.3.5
- v2.3.6
- v2.3.7
- v2.4.0
- v2.4.1
- v2.5.0
- v2.6.0
- v2.6.1
- v2.6.2
- v2.6.3
- v2.6.4
- v2.6.5
- v2.6.6
- Affected ranges
- ECOSYSTEM: < 2.6.7
Update to 2.6.7