p PatchFirst

PatchFirst · Latest vulnerabilities

setasign/fpdi vulnerabilities

Vulnerabilities published for setasign/fpdi in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-45802

    Medium · CVSS 6EPSS 0.26%Fix available

    FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service

    FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.

    • Update to 2.6.7
    Published Updated
  2. CVE-2025-54869

    Medium · CVSS 6EPSS 0.33%Fix available

    FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser

    FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.

    • Update to 2.6.4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →